Oracle warns of CVE-2018-3110 Critical Vulnerability in Oracle Database product, patch it now!

Last week Oracle disclosed a critical vulnerability in its Oracle Database product, the issue tracked as CVE-2018-3110 has received a CVSS score of 9.9,

On Friday, Oracle released security patches to address a critical vulnerability affecting its Database product, the company is urging install them as soon as possible.

The vulnerability resides in the Java VM component of Oracle Database Server, a remote authenticated attacker can exploit it take complete control of the product and establish a shell access to the underlying server.

The vulnerability, tracked as CVE-2018-3110, affects Oracle Database 11.2.0.4, 12.2.0.1, 12.1.0.2 on Windows and 12.1.0.2 running on Unix or Linux.

“Vulnerability in the Java VM component of Oracle Database Server. Supported versions that are affected are 11.2.0.4, 12.1.0.2, 12.2.0.1 and 18.” reads the security advisory published by Oracle “Easily exploitable vulnerability allows low privileged attacker having Create Session privilege with network access via Oracle Net to compromise Java VM. While the vulnerability is in Java VM, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java VM. “

Oracle CVE-2018-3110

The Version 12.1.0.2 on both Windows and Unix/Linux systems was already addressed with the Oracle July 2018 CPU.

“Due to the nature of this vulnerability, Oracle recommends that customers apply these patches as soon as possible.” reads the blog post published by Oracle.

“This means that:

  • Customers running Oracle Database versions 11.2.0.4 and 12.2.0.1 on Windows should apply the patches provided by the Security Alert.
  • Customers running version 12.1.0.2 on Windows or any version of the database on Linux or Unix should apply the July 2018 Critical Patch Update if they have not already done so.”

Oracle “strongly recommends that customers take action without delay.”



Pierluigi Paganini

(Security Affairs – CVE-2018-3110, Oracle Database)


The post Oracle warns of CVE-2018-3110 Critical Vulnerability in Oracle Database product, patch it now! appeared first on Security Affairs.

Leave a Reply